利用OpenWrt为虚拟机做流量代理

安装Openwrt虚拟机

下载镜像:Index of /releases/22.03.5/targets/x86/64/ (openwrt.org)

转换镜像:

1
qemu-img convert -f raw -O vdi openwrt-22.03.5-x86-64-generic-ext4-combined-efi.img openwrt-22.03.5-x86-64-generic-ext4-combined-efi.img.vdi

配置虚拟机网卡:

  1. 在VirtualBox中新建HostNetwork(Host-Only网络),网段为192.168.56.0/24

  2. 在openwrt虚拟机的网络选项中设置:

    1)启用网卡1,连接方式选仅主机网络,名称选上步创建的HostNetwork

    2)启用网卡2,连接方式选桥接网卡,名称选本机上能访问外网的网卡

  3. 进入openwrt虚拟机,为lan口设置静态IP地址为HostNetwork中的一个IP,这里用 192.168.56.2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdd4:bccc:9ebb::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.56.2'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'eth1'
option proto 'dhcp'

config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'

OPENWRT开启SFTP,实现文件下载上传

同时也能使用scp命令进行拷贝

1
2
3
4
opkg update
opkg install vsftpd openssh-sftp-server
/etc/init.d/vsftpd enable
/etc/init.d/vsftpd start

OpenClash安装与配置

1
2
3
#iptables
opkg update
opkg install coreutils-nohup bash iptables dnsmasq-full curl ca-certificates ipset ip-full iptables-mod-tproxy iptables-mod-extra libcap libcap-bin ruby ruby-yaml kmod-tun kmod-inet-diag unzip luci-compat luci luci-base

如果需要强制安装,可以先opkg remove,再opkg install

Releases · vernesong/OpenClash (github.com)页面,将openclash安装包下载到openwrt虚拟机中,通过 opkg install 安装。

配置手册:Home · vernesong/OpenClash Wiki (github.com)

其他虚拟机的旁路由配置

此处用的是ubuntu server,可以在安装界面时设置,也可以等安装完成后,手动修改配置。手动修改的配置如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
$ cat /etc/netplan/00-installer-config.yaml
# This is the network config written by 'subiquity'
network:
ethernets:
enp0s3:
addresses:
- 192.168.56.3/24
nameservers:
addresses:
- 114.114.114.114
search: []
routes:
- to: default
via: 192.168.56.2
version: 2

配置修改后,可以看到默认路由已变成 192.168.56.2

1
2
3
4
$ ip route
default via 192.168.56.2 dev enp0s3 proto static
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown
192.168.56.0/24 dev enp0s3 proto kernel scope link src 192.168.56.3

Reference

Git 操作及原理

Git Diff 的工作原理

Myers差分算法

创建基于某个 commit id 的分支

1
git checkout -b dev c99d6500

查看指定分支的提交

1
2
git log master
git config --global alias.nicelog "log --graph --abbrev-commit --pretty=format:'%Cred%h%Creset -%C(yellow)%d%Creset %s %Cgreen(%cr) %C(bold blue)<%an>%Creset'"

如下所示:

git 如何存储

git 如何 merge

git 如何 rebase

是否能 cherry-pick 所有的 commit

换行符问题

问题Linux 环境执行一些脚本出错,查找原因,发现是文件在Windows环境修改并上传,格式被转换为MS-Dos格式(换行符不同),这样的文件在Linux中运行会出错(shell 解释器把换行符作为一个命令的提交)。背景很久以前,老式的电传打字机使用两个字符来另起新行。回车符(CR,carriag
阅读更多

Windows连接L2TP/IPSec的VPN

Windows系统默认不支持连接在防火墙NAT后的L2TP/IPSec协议VPN,但是可以通过修改注册表解决。

修改方法如下:

  1. 定位注册表 :HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent
  2. 新建DWORD (32位)值,名称:AssumeUDPEncapsulationContextOnSendRule
  3. 值填 2
  4. 重启系统

In order to disable IPSec on Windows 7/Vista

  1. Click Start, then in search box type: run ENTER
  2. In the Run dialog type: regedit ENTER
  3. In Registry Editor: Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters
  4. On the Edit menu, click New>DWORD
  5. As the name of the new key enter: ProhibitIpSec
  6. Double click the key to edit the value.
  7. In the Value data field, enter: 1
  8. Quit Registry Editor, and then restart the computer.

当VPN启动后,还需要修改两项与路由相关的配置

hackintosh如何解决app store无法登录的问题

现象打开 App Store 之后,输入账号&密码之后,登录框就消失了,且软件中并没有显示登录信息,多次尝试后,仍然如此。原因en0 网卡不存在。可以通过 ifconfig en0查看网络适配器是否存在。解决办法移除 NetworkInterfaces.plist$ sudo rm -rf
阅读更多

macOS如何sudo免输入密码

每次使用 sudo 时都要输入密码,太过繁琐。想能像在 Linux 中一样,配置下 /etc/sudoers 文件就能免输入密码,可以一劳永逸。操作先给/etc/sudoers文件加修改权限 sudo chmod u+w /etc/sudoers修改配置 sudo vim /etc/sudoers中
阅读更多

tcpdump cheat sheet

Packet Capturing OptionsSwitchSyntaxDescription-i anytcpdump -i anyCapture from all interfaces-i eth0tcpdump -ieth0Capture from specific interface ( E
阅读更多

VMware Fusion 固定 IP

编辑 DHCP 配置文件sudo vim /Library/Preferences/VMware Fusion/vmnet8/dhcpd.conf做如下修改####### VMNET DHCP Configuration. End of "DO NOT MODIFY SECTION&qu
阅读更多